Headers Authenticator for XWiki

Last modified by Admin on 2017/10/16 00:04

cogXWiki authentication based on HTTP headers
TypeJAR
Developed by

Denis Gervalle, Thomas Mortagne, Ludovic Dubost

Active Installs9
Rating
Rate!
0 Votes
LicenseGNU Lesser General Public License 2.1
Compatibility

Installation of authenticators using Extension Manager is only supported since XWiki 6.0M1

Installable with the Extension Manager

Description

XWiki authentication based on HTTP headers

This authenticator is now superseded by a newer more versatile version available as an adapter for the new trusted authentication framework. From many minor ones, an important limitation of this authenticator compared to the new one, is that user fields are never synchronised for existing users

See https://github.com/xwiki-contrib/xwiki-authenticator-headers/blob/master/README.md

Tested on

This extension has been tested with the following configurations.

Extension VersionXWiki FlavorNotes
2.0XWiki Enterprise 6.2

Extension really requires 6.2 but does not enforce it.

2.0.1XWiki Enterprise 6.2

Extension really requires 6.2 but does not enforce it.

2.0.2XWiki Enterprise 6.2
2.0.3XWiki Enterprise 4.4.1

Prerequisites & Installation Instructions

We recommend using the Extension Manager to install this extension (Make sure that the text "Installable with the Extension Manager" is displayed at the top right location on this page to know if this extension can be installed with the Extension Manager). Note that installing Extensions when being offline is currently not supported and you'd need to use some complex manual method.

You can also use the manual method which involves dropping the JAR file and all its dependencies into the WEB-INF/lib folder and restarting XWiki.

Release Notes

v2.0.3

This is almost the exact same release as the previous one, but it lowered the requirement for XWiki code to XWiki 4.4.1 or later.
(Since the unit testing mocker is only available since 6.2, the testing part of the refactoring has been put aside in a branch, and will be applied during an upgrade to 6.4 or later.)

v2.0.2

This is almost the exact same release as the previous one, but it correctly enforce the requirement on XWiki core to 6.2 or later.

v2.0.1

This is almost the exact same release as the previous one, but it is now exposed with a better extension  ID.

v2.0

This is a complete refactoring of the original extension published in the contrib sandbox. Code is now fully unit tested thanks to the recent MockitoOldcoreRule mocking.

TODO: User synchronization of existing users. Currently, user fields are only applied at creation time.

Dependencies

Dependencies for this extension (org.xwiki.contrib.authentication:xwiki-authenticator-headers 2.0.3):

  • org.xwiki.platform:xwiki-platform-oldcore 4.4.1
Tags:
Created by Denis Gervalle on 2014/12/03 14:11
    

Get Connected