From version 6.26
edited by Clemens Robbenhaar
on 2019/10/12 14:31
To version 7.1
edited by Clemens Robbenhaar
on 2019/10/12 14:35
Change comment: explanation of error nessage after update added

Summary

Details

ExtensionCode.ExtensionClass[0]
Prerequisites & Additional Installation Instructions
... ... @@ -11,3 +11,13 @@
11 11  {{/code}}
12 12  
13 13  Afterwards you need to restart the XWiki server to makes these changes effective.
14 +
15 +== Error message after update ==
16 +
17 +If you get an error message after updating the extension, like:
18 +
19 +{{warning}}The Blocking Authenticator is not the configured authentication service. Please set xwiki.authentication.authclass=org.xwiki.contrib.authentication.blocking.internal.BlockingAuthServiceImpl in your xwiki.cfg.{{/warning}}
20 +
21 +this means the old version is still running and the UI does not figure out that this is another verison of the same authenticator.
22 +
23 +You need to restart the XWiki to get rid of this message. Unless you restart, the old version still blocks login attempt an keeps your wiki secure, but you cannot view the blocked users and IPs or unblock them via the UI.

Get Connected