• Jean SIMARD
    Jean SIMARD, 2013/11/08 15:28

    Hi, I just installed this extension from the "More applications" link (in the right panel) on a fresh 5.2. I also try the XAR importation to install it. However, in both cases, I did not see what I should. In Collections.WebHome, the 'type' field is not proposing the 'static' and 'query': the list is empty.

    Moreover, on the Main.WebHome, I did not see the 'Collections' space. It seems that XWiki does not refresh the list or something like that.
    Is it a compatibility problem with 5.2 or is it a problem with my installation?

    • Jean SIMARD
      Jean SIMARD, 2013/11/08 15:59

      I answer my second questions myself. I installed a new XWiki to try to reproduce the bug but forget to reveal hidden files in the Admin profile. They were just hidden. But I still have an empty list for Collection's type.

      • Marius Dumitru Florea
        Marius Dumitru Florea, 2013/11/12 10:23

        Hi Jean, the following is written right at the start of this page:

         When installed, it adds an entry to the Applications panel that links to the home page.

        and there is even an image. Why do you need to have 'Collections' in the space list when you have it in the list of applications? It's an application you installed after all.

        Regarding the empty 'type' field, this is indeed a problem, caused by the fact that the dependencies required by this extension have not been installed by the Extension Manager. We're currently investigation this. In the mean time, what you can do to fix the problem is to use the Advanced extension search to install:

        Extension Id: org.xwiki.contrib:application-collection-api
        Version: 1.0
        • Jean SIMARD
          Jean SIMARD, 2013/11/12 16:08

          Hi Marius,

          Thanks for the answer.

          OK for the Panel, I saw that. However, I was looking for the templates in order to find a solution to my problem, that's why I was looking for the 'Collection' space. I was just trying to create a new collection from the template. However, I think I do not understand XWiki enough to do that ;-)

          And thanks for the info about the Collection API, the extension works fine now.

Get Connected